Sunday, 30 October 2016

Upgrading the Amiga 1200 Part 3

Hello and welcome to Part 3 of my Amiga 1200 Upgrade series! Today I am working on upgrading the CF Card on the Amiga 1200, which involves a full data transfer from the existing 4GB card to a new 8GB card using the Amiga 4000T, and upgrade from ClassicWB to AmigaOS3.9 and AmiKit Real 8.1 too!

For those who may have missed them, the original A1200 arrival in October, Part 1 and Part 2 posts are here so you can catch up from the start and avoid me rehashing material already covered.

As you may recall in Part 2 I purchased a TrueIDE card (made by Individual Computers). At the time I was trying to work out how to connect floppy power connection to it given the use of the existing RapidRoad pass through floppy connector on the Amiga 1200 board.

I then hit problem number two - one I really should have thought through before buying it...the connection is 3.5 not 2.5, so it needs to be mounted on the left side of the 4 way IDE adapter on my Amiga 1200, which means it doesn't fit inside the case anyway with CF cards in it!

The TrueIDE card assumes it is directly connected to the IDE male connector (ie. no standard IDE ribbon cable can be connected to it). This works great in large Amiga cases and PC cases, but not the A1200:

 I connected up a external floppy drive power source to test things out, and then saw the problem very clearly when connecting the CF cards to it.

Even with this setup correctly and the external power connected, I couldn't get the trueIDE to be detected by the system. To simplify things I moved the bootable 4GB CF card that I know works into the True IDE by itself and removed the 2.5 CF card adapter and cable, leaving just the TrueIDE connected to the 3.5 primary connector on the 4 way IDE adapter:

No Go.

I tried populating both ports and using the 4 second reboot thing to switch the primary in case it was set wrong, but made no difference either.

A little frustrated by this stage, I pulled apart the adjacent Amiga 4000T, removed all the IDE connectors from the Buddha IDE card, and connected the TrueIDE to it to test (with floppy power connected of course):

That didn't work either...The system kept constantly rebooting with it plugged in...

So I decided to give up on the TrueIDE completely for now. I put the Amiga 4000T IDE connectors back on the Buddha card and booted it up straight away as normal, proving that the IDE ports work fine.

Why the 8GB CF card? The 4GB CF card supplied to me with the Amiga 1200 was completely full, and I mean full. 467k free...I wanted to do lots with the Amiga 1200 but the CF card being full was a problem I had to address!

I already had a 8GB CF Card spare available (which I normally use on the AmigaOne X1000 CF Card slot for booting Linux kernels but haven't used for a long time), so I decided to use that. Besides, the 8GB was wasted there as I really only need 1GB for that card. I will repurpose another smaller CF card for that role in the future if needed...

I also made the decision to utilise the USB support (via Deneb USB card) on my A4000T to prep the 8GB CF card using a USB CF card reader. I wanted to keep this all work confined on the original Amiga hardware as much as possible. I could then copy across the contents I want to use on the Amiga 1200, and there is a lot to I quickly got to work.

I prepped the CF Card using usbscsi.device in HDToolbox on the Amiga 4000T, using three partitions - 1.8GB UDH0 named Workbench, 3.7GB UDH1 named Data1 and 1.8Gb UDH2 named Data2:

I left the device names UDH0, etc, because I already have DHx and HDx series on my A4000T and want to avoid clashes, and make it easy to connect the CF card anytime in the future for large file transfers if needed.

With the partitions and devices set I then saved the partition detail and disconnected the USB reader and reconnected and the partitions could then be formatted from Shell using the usual

Format drive UDH0: NAME Workbench FFS QUICK

I then used the RapidRoad on the Amiga 1200 to copy the contents of the 4GB CF card to a FAT32 64GB usb stick, and then connected it to the A4000T to copy the data to the new 8GB CF Card.

Important things I also copied across was the AmigaOS3.9 CD contents to a Temp/AmigaOS39 folder, the Boing Bag 3.9-1 and 2 updates, and the AmiKit Real 8.1 setup files to the Workbench partition of the 8GB CF card.

With all this done (which I left running overnight on the saturday night as the number of files is considerable on the Amiga 1200 and Amiga 4000T side to copy across). In the morning I checked and it was completed.

The original Workbench partition on the 4GB CF Card was a ClassicWB installation using 50MB space. The partition wasn't much bigger than this, which made it unworkable for upgrading to AmigaOS3.9 and definitely not able to upgrade to AmiKit Real either. The new 1.8GB partition should work great.

I connected the new 8GB CF Card to the 2.5" IDE to CF Card converter in the A1200 and booted into the ClassicWB environment transferred from the old 4GB Cf Card. So far so good, except that I can't see the Data1 and Data2 partitions. I presumed that this was because the partitions where created and formatted using a newer FastFileSystem version than ClassicWB knows about.

I figured upgrading to AmigaOS 3.9 would fix this problem, so I got to work with that task next. As usual I assigned AmigaOS3.9 to the drawer where I copied the AmigaOS 3.9 install files as it is needed for the installation, and for the Boing Ball 1 and 2 updates too.

As this ClassicWB install is a simple OS3.1 base install, I could upgrade it:

The install then got underway.

All done - I rebooted the system:

Now with AmigaOS 3.9 installed,  the desktop looks a little strange but I'll clean that up later...

I then got to work installing the Internet Software component of AmigaOS 3.9, which needs to be installed after the initial installation - again I had to do the assign before running the installation again:

With the Internet software (Mainly the Genesis and AMITCP stack installed), I could then install Boing Bag 1 and 2 updates for AmigaOS 3.9:

Boing Bag 1 done - after a reboot I got onto Boing Bag 2:

I hit a problem with the ROM update installed as part of Boing Bag 2, and needed to boot no startup and modify the s:startup-sequence SetPatch line to skip the rom updates for scsi.device (as below).

Then the system booted normally following the update.

With the Boing Bags installed, I then renamed the Workbench partition to AmiKit in preparation for the next section of the installation - installing AmiKit Real 8.1 on the Amiga 1200!

First though I removed the source AmigaOS 3.9 files and boing bag updates since I no longer needed them to free up some space for the AmiKit Real installation.

I played around with the screen mode and fonts settings to make things a bit nicer but to be honest it wasn't needed so I haven't showed those steps. I then started the AmiKit Real 8.1 installation:

I covered this installation in a lot of detail on my earlier AmiKit Real blog posts (Part 1 and Part 2) on getting AmiKit Real 8.1 working on the Amiga 4000T, so here I will just focus on the sections of the installation specific to the Amiga 1200. You get one warning before everything is overwritten by AmiKit Real:

The file extraction then gets underway and takes quite a long time. When it does finish you get the completion prompt to reboot your machine:

On reboot we now get the AmiKit Real 8.1 boot screen and we know things are going well:

The initial Workbench comes fairly quickly, although not as fast as the original ClassicWB build of course! But looks a hell of a lot better too:

I set to work with some localisations for Australia and Adelaide - date and time settings, etc.

I picked a small iff Amiboing backdrop to keep chip memory usage down on the integrated Dopus workbench replacement setup in AmiKit Real:

Things are looking good! The extra memory on the ACA1233-55 comes in real handy when using AmiKit Real. It is still important to optimise the Chip memory usage since the Amiga 1200 does not have the RTG option available. Still looks nice though in my opinion!

I then needed to reinstall the Poseidon software for the USB support to work again using the Rapid Road - must have been lost during the AmigaOS 3.9 / Amikit Real installations. Easy fixed though.

With AmiKit Real now installed with USB support again I now have sgrab, so I can start taking screenshots to upload to this blog entry rather than grainy iPhone pictures! Here I am playing some modules through Hippoplayer:

The Prefs drawer under AmiKit Real 8.1 on the Amiga 1200 looks great:

There is still a lot more work to do - getting internet working via PCMCIA WiFi card to download the latest version updates for AmiKit Real 8.1 to 8.6 current release, adding MAS Player hardware, etc, but that is for another time as I have run out of time for the weekend.

Time to relax and enjoy a 030 AGA demo or two on my newly upgraded Amiga 1200/030-55 with RapidRoad USB running AmiKit Real...Shaft 7 by Bomb - yes I think so...

I then put the Amiga 1200 back together as it will probably be at least next weekend before I can do more with it.

I hope you enjoyed this series so far and hopefully I'll see you for the next part of my Amiga 1200 upgrade series soon!

Saturday, 29 October 2016

Upgrading the Amiga 1200 Part 2

It is great to be working on my Amiga 1200 again this weekend! Today in Part 2 of the Amiga 1200 upgrade I am looking at the installation of Individual Computers ACA1233-55 (030-55Mhz accelerator) and the rather excellent Individual Computers Rapid Road USB clock port expansion, amongst other things!

For those who missed Part 1 and the earlier posts on this recently acquired Amiga 1200, please check here and here to catch up!

What can I say - I did some serious shopping! I bought a lot of stuff from and Individual Computers for projects on my Classic Amiga (not just the A1200) - more on those later on.

Today I focus on the A1200 projects. Here is the ACA1233-55 accelerator board, RTC (Real Time Clock battery) module for it, and TrueIDE for adding two CF cards to your Amiga 1200:

Some close up shots of the ACA1233-55. This board is only available directly from Individual Computers to my knowledge, which features an overclocked 68030 processor running at 55Mhz, with 128MB memory onboard.

It also has a clockport expansion port, which disappointedly is ONLY for the RTC module. Unlike the newer ACA1233n 030-25 which allows the Rapid Road to be connected to this port!

The decision not to update the 1233 while overclocking it safely to 55Mhz to include a Rapid Road compatible port baffles me for an expensive top level 030 card.

Anyway, here is the back of the board:

There is provision to solder on an FPU and associated crystal, but I lack to skills to do this so it will remain stock for now.

Here is the TrueIDE card from Individual Computers. As mentioned earlier it allows two CF cards to be installed.

What makes this different to the regular IDE to CF adapters is that it has circuitry in it to present the normally removable devices (under AmigaOS) to be fixed devices, allowing booting any OS from the cf cards. In addition a 3 second reset hold will boot the second cf card automatically, avoiding the need to select every time,

It also has two different mounting connections, allowing easy connection horizontally (in Amiga 1200/600, etc), or vertically in larger cases like the A4000D, and to Zorro card IDE adapters. It does require floppy power connection to the card though, and this presents a problem in an Amiga 1200 since there is only one floppy connector power cable connection available..I decided to shelve the TrueIDE for this part as I don't have a solution to that yet.

Moving on, here is the Rapid Road USB 2.0 clock port card:

Also included with the card is a floppy power connector for pass through on an Amiga 600/1200, clock port cable and USB 2.0 header cable with 2xUSB 2.0 ports on a Small form factor case expansion port mounting. There is also a floppy disk with the required Poseidon USB stack and Rapid Road USB drivers on it:

Interesting is that the whole board is covered in heat resistant solid perspex like material (I assume) to protect the unit from shorting inside the Amiga 1200/600 case. Nice thinking:

This card can be mounted on an Individual Computers A604n expansion on the A600, some ACA1233n accelerators, connected to an Individual Computers x-surf 100 card, or the clock port expansion directly on the A1200/600. There are options to connect it to other clock port expansions released for the Amiga over the years too:

Ok, so let's get these setup! First things first, the accelerator as it is the easiest to install. I flip over the Amiga 1200 case ready to pop out the expansion cover:

Here you can see the current ACA1233n with RTC module I installed in Part 1, alongside the brand new ACA1233-55 card:

Being lazy, I chose to put the RTC module from the 1233n card onto the A1233-55 card to avoid having to find another battery for the new RTC module I is the RTC module installed:

Here is the ACA1233-55 installed in the A1200 - it fits easily:

I hooked up the Amiga 1200 and booted up, all good so far - the extra 128MB memory is available.

Running SysInfo we can see the performance of the new A1233-55Mhz board - I understood the board runs at 55Mhz but SysInfo reckons it is 60.50Mhz! If so, then it is very nice improvement over the ACA1233n-25Mhz card I had in the A1200 before:

Here is the A1233n-25Mhz board SysInfo screenshot for comparison:

 The card has 127MB + 1MB in reality. Anyway, here is 127MB Fast memory in SysInfo:

1MB slow memory is also included in the card, bringing it up to 128MB:

And here of course is the case 2.0MB CHIP that comes standard on the A1200:

Here I am enjoying Essence's Crazy Sexy Cool demo, which runs smoothly on the new 030 55Mhz accelerator:

Ok, having established the new accelerator works well, I moved on to installing the Rapid Road USB clock port expansion. This requires disassembling the A1200, so I got to work on that:

Closer view of the new accelerator installed in the now disassembled A1200:

Here is the Rapid Road, ready for installation:

Note that the printed instructions included with the Rapid Road are essentially useless. You need to go to the Wiki for Individual Computers for the real installation instructions, which includes the really important photos of how the device needs to be installed. Seriously, please include these in the printed instructions! The link to the instructions I used is here.

You can also download the ADF of the install disk - which I had to do too since the floppy disk I was given had a read error on it...I wrote our the ADF using Kryoflux on my MacBook Pro (could also use my X1000 or TransADF on a Classic Amiga) to a fresh floppy disk and then I was good to go.

The important thing when installing in a A1200 is the correct orientation of the clock port cable. If you get it the wrong way around you will destroy the Rapid Road.

There is two floppy power connectors on the Rapid Road. One goes to the power connector on the A1200 board. The other passes through to the A1200 floppy drive. That way power devices can be powered from the single power connector!

Closer view of the power pass through arrangement - I really like this feature.

I then routed the ground cable to the spare screw hole on the Amiga 1200 as per the instructions on the Wiki and screwed it in:

I then partially reassembled the Amiga 1200 to check things over:

As you can see the Rapid Road fits perfectly in the A1200:

Here is my (now fixed) installed floppy disk, ready to install the Rapid Road drivers and Poseidon.

I then powered on with a sense of worry about whether I put the Rapid Road clock port cable the right way around...helpfully it lights up white immediately to indicate it it correctly oriented, and all was good!

So I inserted the floppy disk on got on with the install.

As part of the install it installs Poseidon USB stack - note that this needs MUI 3.8+ installed, so if you don't have that installed, you need to install it first.

The new Rapid Road USB drivers are also installed:

I nominated to install the Poseidon software to run on startup. I then finished the installation, installed the fat95 program when prompted (needed for FAT32 drive support) and then rebooted.

Next I ran the Trident (Poseidon) Prefs in the Prefs drawer to configure it for using the new drivers - select the Controllers section and add the Rapid Road device using the rapidroadcpusb.device (the clock port version of the driver):

We are now connected and the USB 64GB flash drive I installed is picked up straight away.

One of the big features of Rapid Road is the support for USB 2.0 and the support to run removable hard disks (not just flash drives) without the need of a powered USB hub.

I tested this by connecting up my 1TB Western Digital USB drive, which I normally use with my MorphOS Powerbook, and contains all my Amiga system and data files for easy transfer to different machines. It fits nicely on top of the floppy drive as below:

The drive worked perfectly with the Rapid Road! This positioning of the drive has got me thinking to get a slimline USB hard disk that could sit there permanently...hmmmm...

Anyway, for now I decided to run my old demo group The Experience demos, which needs an 030-40 or better to run well:

This is a sad and nice moment for me, reminding me of my friend Mark (Axon), the coder of this demo "Terminal" back in 1998, who sadly passed away a little over a year ago now. Thanks for the great memories mate!

The demo ran perfectly on the new accelerator, running off the USB hard disk connected to the Rapid Road!

I still need to decide how to mount the USB ports since I have already used the expansion port at the rear for the DVI output from the Indivision AGA Mk2. Hmm, not sure yet. For now I decided to route the cable through a small gap in that port and under the floppy drive to the Rapid Road internally until I work out another way. Thoughts anyone?

Here is the Amiga 1200 all re-assembled again, with the USB ports running through the expansion port temporarily so I could close the case up.

I then connected a USB flash drive to the Rapid Road to make sure everything still works and it did - excellent!

Well, this seems like a good point to stop for now. That concludes Part 2 of the Amiga 1200 upgrade. There is more to do of course, and I will cover this in a future blog entry!